Self-Hosted Supla + Varilight v-pro in Home Assistant

rich_mus
Posts: 2
Joined: Wed May 01, 2024 4:27 pm

Post

Hi All,
I've had a look through the forums and wasn't able to find the answer to this query. Apologies if it has been already answered and I missed it!

I've got a self-hosted supla instance on a proxmox VM running ubuntu, using docker/portainer, to use with a Home assistant (HAOS) installation on another VM. I'm trying to use 3 varilight v-pro dimmers that I have previously had working via supla cloud/MQTT. My aim is to have the entire system to be available 'offline' in the event of (unfortunately frequent) internet outage.

As far as I understand:
a. V-Pro hardware doesn't have MQTT chip so cannot be used without a supla instance
b. Dimmers aren't supported by the supla server/token integration with HA [?but might be possible to add with the rest API?]
c. Failing that, MQTT should do the trick (it worked when I was using SUPLA cloud/MQTT server) - but requires further configuration

So my question is:

1. Is it possible/easy to add dimmers to the REST API on my self-hosted server?
or
2. How do I get the self-hosted supla instance to communicate using MQTT? - in essence replicating the supla MQTT server setup but locally.

Thanks in advanced for your help,

Rich
rich_mus
Posts: 2
Joined: Wed May 01, 2024 4:27 pm

Post

Embarrassingly, after a bit of a dive into the Polish forum, I have found the answer and got it working! - it was incredibly obvious but am posting here step-by-step just in case anyone else is stuck in same situation and also didn't have much experience with MQTT.

Simply, from the supla side, the MQTT broker needs to be enabled in docker compose, I have no idea why i didn't see those setting initially, it wasn't until I discovered that there is native mqtt support (fab feature btw, thanks team!) that I went looking.

Supla instance side:

In docker compose/Portainer environment variables, find and change the following:

MQTT_BROKER_ENABLED=true
MQTT_BROKER_HOST= IP Address of your HA
MQTT_BROKER_PORT=1883
MQTT_BROKER_TLS=false
MQTT_BROKER_USERNAME= Get from HA
MQTT_BROKER_PASSWORD= Get from HA

Set up your MQTT on HA:

[If migrating from an existing MQTT setup with supla cloud mqtt servers, i believe it is most straightforward if you remove the mqtt integration and uninstall/reinstall mosquitto broker to ensure that the integration auto detects properly]

1. Install Mosquitto Broker in Home Assistant - from the add on store; start it and then check it is running in 'log'
2. Activate MQTT integration: Settings -> Devices and Services; MQTT should be auto-detected - activate it, then retrieve username and password from the configure -> reconfigure MQTT (under MQTT settings). Check the port is 1883 as above.

Once you've popped those variables into docker compose, restart the container and boom, devices found instantly.

Thanks again supla team, it's great to be able to use this hardware locally :)

R
User avatar
pzygmunt
Posts: 18613
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków

Post

I'm glad you were able to configure MQTT. Perhaps V-Pro smart will receive an update someday that will add local support for MQTT.

Return to “Help”