How to get Supla devices in Home Assistant without MQTT?

bremenpl
Posts: 8
Joined: Fri Apr 21, 2023 7:42 am

Post

Hi, thanks for ther reply.
Thing is, I have bo idea where in the gui that would be.
User avatar
klew
Posts: 8776
Joined: Thu Jun 27, 2019 12:16 pm
Location: Wrocław

Post

bremenpl wrote: Mon Apr 24, 2023 5:01 am Hi, thanks for ther reply.
Thing is, I have bo idea where in the gui that would be.
Please check this:
https://www.home-assistant.io/integrations/mqtt/

There is "manual configuration steps" part.
I haven't tried it myself, but I guess that instruction is updated, since people from HA forum linked this page.
Widzimy się na Supla Offline Party vol. 2 :!:
bremenpl
Posts: 8
Joined: Fri Apr 21, 2023 7:42 am

Post

That was it, thanks!
topolino65
Posts: 12
Joined: Mon Jun 26, 2023 5:51 am

Post

Im trying to get my supla home+ heater to show up in Home Assistant, what is the basic MQTT yaml code to put into my configuration.yaml file and where can I find my credentials. (I can currently only control the radiator remotely via the Supla app or through Alexa). Also I have the HA MQTT broker running which is currenly setup to listen to my diesel heater. Is it possible in HA to have the MQTT broker listen to the Supla raidiator as well?
User avatar
pzygmunt
Posts: 18613
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków

Post

Cloud supports MQTT discovery.
https://drive.google.com/file/d/10HTT6j ... KQwb3/view

I only have a version in Polish, so use Google Translate.
topolino65
Posts: 12
Joined: Mon Jun 26, 2023 5:51 am

Post

HI, thanks for the info. I have the MQTT broker add-on already running on my Home Assistant set up that talks to a diesel heater. However the MQTT add-on will only let me configure it (in the GUI) to connect to ONE device not two. I can connect to my Supla device via the MQTT Explorer desktop program on my PC perfectly. What I need is to be able to allow the MQTT add-on in Home Assistant, to talk to my Supla device, as well still talk to my existing diesel heater. Is there a way to do this?

I read your attached document and the section on SSH but I am not sure if that method will allow me to use two devices through one broker on HA. If that is the solution to my problem, can you give me some more simple guidance on SSH commands, as when I try to type in "mkdir-p/share/mosquitto" nothing happens.
User avatar
pzygmunt
Posts: 18613
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków

Post

If you already have your local broker, configure the bridge to mqttX.supla.org according to the instructions.
topolino65
Posts: 12
Joined: Mon Jun 26, 2023 5:51 am

Post

I created a mosquitto.conf file in the share folder. Can you please show me te syntax I should add into this file. At the moment I have...

connection Supla
address "mqtt37.supla.org"
remote_username c0ea48db06c2fe59xxxxxxxxxx
remote_password zpjlckwETTXf94kxxxxxxxxxxxx
topic supla/c0ea48db06c2fe59af73fc708916cd52

In my MQTT logs I see this

2024-01-07 23:11:23: Warning: Mosquitto should not be run as root/administrator.
2024-01-07 23:11:23: mosquitto version 2.0.18 starting
2024-01-07 23:11:23: Config loaded from /etc/mosquitto/mosquitto.conf.
2024-01-07 23:11:23: Loading plugin: /usr/share/mosquitto/go-auth.so
2024-01-07 23:11:23: ├── Username/password checking enabled.
2024-01-07 23:11:23: ├── TLS-PSK checking enabled.
2024-01-07 23:11:23: └── Extended authentication not enabled.
2024-01-07 23:11:23: Opening ipv4 listen socket on port 1883.
2024-01-07 23:11:23: Opening ipv6 listen socket on port 1883.
2024-01-07 23:11:23: Opening websockets listen socket on port 1884.
2024-01-07 23:11:23: mosquitto version 2.0.18 running
2024-01-07 23:11:23: New connection from 127.0.0.1:41044 on port 1883.
2024-01-07 23:11:23: Client <unknown> disconnected due to protocol error.


Can you help? I really dont where to go from here
topolino65
Posts: 12
Joined: Mon Jun 26, 2023 5:51 am

Post

OK so I have set the mosquitto.conf file to now show this according to your PDF file

connection bridge-Enigmaxxxx
address mqtt37.supla.org:8883
supple topic/# in
topic homeassistant/# in
topic supla/+/devices/+/channels/+/execute_action out
topic supla/+/devices/+/channels/+/set/+ out
remote_username c0ea48db06c2fe59af73fcxxxxxxx
remote_password zpjlckwETTXf94kFQy*REwrxxxxxx*
bridge_capath /etc/ssl/certs

However when I enable in the mQTT addon active: false to active: true

The MQTT add on fails to start. I should mention I have the .py files under custom components/supla/ folder (init.py, cover.py etc). I also lose my local connection to the MQTT broker on HA (192.168.1.176)
User avatar
pzygmunt
Posts: 18613
Joined: Tue Jan 19, 2016 9:26 am
Location: Paczków

Post

Remove csutom integration with Supa (we only support MQTT integration). Check the mosquitto logs.

Return to “Help”