SOnOff TH10 not booting with Supla. Help!

MilanGajic
Posts: 12
Joined: Wed Nov 13, 2019 9:11 pm

Wed Nov 13, 2019 9:31 pm

Hello everyone,

I'm new to this forum and to Supla ...and I have a little problem.

I've been trying to flash Supla (sonoff_th10_user1.1024.new.2.bin) to my Sonoff th10, but I just can't get it to boot after flashing.

I'm using NodeMCU and the flashing seems to go allright.

When it's done, I unplug the FTDI adapter and connect it to mains (230V).

The TH10 does not boot, no blinking leds, no WiFi AP, button does not work.

If I reflash Tasmota everything works just fine.

Thank you in advance for any help.

Best regards,
Milan
2019-11-13 22_26_34-Clipboard.jpg
2019-11-13 22_26_34-Clipboard.jpg (148.83 KiB) Viewed 1291 times
User avatar
lesny8
Posts: 1261
Joined: Mon Dec 11, 2017 9:43 pm

Wed Nov 13, 2019 9:46 pm

You used the wrong address for the firmware file and didn't upload the chip initialization file. Follow the readme.txt file.
https://github.com/SUPLA/ESP8266/tree/master/sonoff_th

Edit:
Use FlashDownloadTools
MilanGajic
Posts: 12
Joined: Wed Nov 13, 2019 9:11 pm

Wed Nov 13, 2019 10:24 pm

Ok, thank you lesny8.

I actually just figured it out myself and followed the guide here:
https://www.smartnydom.pl/wgrywanie-fir ... do-sonoff/

Unfortunately still the same issue :(

I tried DOUT and QIL
2019-11-13 22_56_25-NODEMCU FIRMWARE PROGRAMMER.jpg
2019-11-13 22_56_25-NODEMCU FIRMWARE PROGRAMMER.jpg (62.48 KiB) Viewed 1277 times
2019-11-13 22_55_58-Instructies voor het uploaden van Supla naar Sonoff_ stap voor stap - Smart'ny H.jpg
2019-11-13 22_55_58-Instructies voor het uploaden van Supla naar Sonoff_ stap voor stap - Smart'ny H.jpg (53.73 KiB) Viewed 1277 times
2019-11-13 22_56_42-NODEMCU FIRMWARE PROGRAMMER.jpg
2019-11-13 22_56_42-NODEMCU FIRMWARE PROGRAMMER.jpg (52.82 KiB) Viewed 1277 times
User avatar
lesny8
Posts: 1261
Joined: Mon Dec 11, 2017 9:43 pm

Wed Nov 13, 2019 10:36 pm

Upload one more file:
esp_init_data_default.bin---->0xfc000

In the readme.txt file is written:
boot_v1.5.bin -------->0x00000
sonoff_th10_user1.1024.new.2.bin---->0x01000
esp_init_data_default.bin---->0xfc000

BAUDRATE: 115200
Flash Size: 1MByte (8Mbit)
Flash speed: 40Mhz
SPI Mode: DIO


Upload all files on these settings.
MilanGajic
Posts: 12
Joined: Wed Nov 13, 2019 9:11 pm

Wed Nov 13, 2019 10:38 pm

@lesny8:

i tried using the flash_download_tools, but got the same results:
2019-11-13 23_23_19-ESP8266 DOWNLOAD TOOL V3.6.6.jpg
2019-11-13 23_23_19-ESP8266 DOWNLOAD TOOL V3.6.6.jpg (99.79 KiB) Viewed 1270 times
reflashed TASMOTA ... still works :?
User avatar
lesny8
Posts: 1261
Joined: Mon Dec 11, 2017 9:43 pm

Wed Nov 13, 2019 10:42 pm

Clean the chip using the Erase button and then upload all three files with the settings as I wrote.
MilanGajic
Posts: 12
Joined: Wed Nov 13, 2019 9:11 pm

Wed Nov 13, 2019 10:44 pm

lesny8 wrote:
Wed Nov 13, 2019 10:36 pm
Upload one more file:
esp_init_data_default.bin---->0xfc000

In the readme.txt file is written:
boot_v1.5.bin -------->0x00000
sonoff_th10_user1.1024.new.2.bin---->0x01000
esp_init_data_default.bin---->0xfc000

BAUDRATE: 115200
Flash Size: 1MByte (8Mbit)
Flash speed: 40Mhz
SPI Mode: DIO


Upload all files on these settings.
readme says this:
SUPLA FOR ITEAD SONOFF TH10/16
boot_v1.5.bin -------->0x00000
TH10
sonoff_th10_user1.1024.new.2.bin---->0x01000
TH16
sonoff_th16_user1.1024.new.2.bin---->0x01000
BAUDRATE: 115200
Flash Size: 1MByte
Flash speed: 40Mhz
SPI Mode: QIO

esp_init_data_default.bin is not in the ZIP file ... where do I get it?
can i just use the one from here: https://github.com/SUPLA/ESP8266/tree/master/sonoff

I downloaded from this link (provided on the Supla download page):
https://drive.google.com/file/d/0B3DJSA ... RXSWM/view
Patryk
Posts: 890
Joined: Mon Jan 07, 2019 7:51 pm

Wed Nov 13, 2019 10:47 pm

And
FLASH SIZE - 8Mbit
Patryk
Posts: 890
Joined: Mon Jan 07, 2019 7:51 pm

Wed Nov 13, 2019 10:51 pm

MilanGajic wrote:
Wed Nov 13, 2019 10:44 pm
lesny8 wrote:
Wed Nov 13, 2019 10:36 pm
Upload one more file:
esp_init_data_default.bin---->0xfc000

In the readme.txt file is written:
boot_v1.5.bin -------->0x00000
sonoff_th10_user1.1024.new.2.bin---->0x01000
esp_init_data_default.bin---->0xfc000

BAUDRATE: 115200
Flash Size: 1MByte (8Mbit)
Flash speed: 40Mhz
SPI Mode: DIO


Upload all files on these settings.

esp_init_data_default.bin is not in the ZIP file ... where do I get it?
can i just use the one from here: https://github.com/SUPLA/ESP8266/tree/master/sonoff
Yes
MilanGajic
Posts: 12
Joined: Wed Nov 13, 2019 9:11 pm

Wed Nov 13, 2019 10:53 pm

flashed again ... still nothing :(
2019-11-13 23_51_41-ESP8266 DOWNLOAD TOOL V3.6.6.jpg
2019-11-13 23_51_41-ESP8266 DOWNLOAD TOOL V3.6.6.jpg (100.51 KiB) Viewed 1256 times
Post Reply

Return to “Help”