Mail configuration problem

Post Reply
davidlin147
Posts: 3
Joined: Wed May 20, 2020 1:16 pm

Wed May 20, 2020 1:28 pm

My own sever not send mail confirmation of the account creation.
this is my supla docker .env file
# Where the SUPLA Cloud will be accessible? Put domain or IP address here with port.
CLOUD_DOMAIN=115.74.124.134
# Initial user account details; delete these settings after the first launch
FIRST_USER_EMAIL=xxxxxxxjie@gmail.com
FIRST_USER_PASSWORD=xxxxxxxx160
# Google ReCaptcha settings
RECAPTCHA_ENABLED=false
RECAPTCHA_PUBLIC_KEY=
RECAPTCHA_PRIVATE_KEY=
# Mailer settings (SMTP)
MAILER_HOST=smtp.gmail.com
MAILER_PORT=587
MAILER_USER=xxxxxxxjie@gmail.com
MAILER_PASSWORD=xxxxxxx160
MAILER_ENCRYPTION=tls
MAILER_FROM=zyuyingjie@gmail.com
# If you want to be notified about some server errors, set this
ADMIN_EMAIL=
# Where to store SUPLA Cloud's data
VOLUME_DATA=./var
# On which ports the SUPLA Cloud shoAccount Activationuld listen (only if standalone mode)
PORT_HTTP=80
PORT_HTTPS=443
REQUIRE_REGULATIONS_ACCEPTANCE=false
REQUIRE_COOKIE_POLICY_ACCEPTANCE=false
BRUTE_FORCE_AUTH_PREVENTION_ENABLED=true
ACCOUNTS_REGISTRATION_ENABLED=true
# These options protect your application
DB_PASSWORD=5vKHikKhYRkH6CbxY7XU1vW2bJuJTyvP
SECRET=tD7phcwV8XQWJabF7gkqOtkQg2XmSAh8
COMPOSE_PROJECT_NAME=supla
COMPOSE_PATH_SEPARATOR=:
COMPOSE_FILE=docker-compose.yml:docker-compose.standalone.yml:docker-compose.arm32v7.yml
~
Someone who knows how to fix this problem, reply to help me. please.
thanks.
lukfud
Posts: 230
Joined: Thu Nov 23, 2017 11:33 pm
Location: Warszawa

Wed May 20, 2020 3:08 pm

https://support.google.com/accounts/answer/185833?hl=en

You probably need to generate an application password. I checked with port 465 (SSL) - it works.
.newbie
davidlin147
Posts: 3
Joined: Wed May 20, 2020 1:16 pm

Thu May 21, 2020 1:12 pm

I created application password but it does not work. I created an account but it didn't send me the activation mail.
lukfud
Posts: 230
Joined: Thu Nov 23, 2017 11:33 pm
Location: Warszawa

Thu May 21, 2020 2:21 pm

Change the port and encryption in the .env file and try again.
After editing the .env file, run the command:

Code: Select all

./supla-docker/supla.sh start
.newbie
davidlin147
Posts: 3
Joined: Wed May 20, 2020 1:16 pm

Fri May 22, 2020 1:09 pm

It worked. thanks bro.
lukfud
Posts: 230
Joined: Thu Nov 23, 2017 11:33 pm
Location: Warszawa

Fri May 22, 2020 1:33 pm

👍
.newbie
Post Reply