thermostat with Oled display

Michal81
Posts: 55
Joined: Sun Feb 02, 2020 9:03 pm

Sun Feb 23, 2020 9:12 pm

Thank you. My work is on, I look forward to Monday - bin without a window, inverted heating / cooling.
And the peak of happiness would be with hysteresis below the set temperature.
I wish you a nice day.
elmaya
Posts: 911
Joined: Wed Jun 27, 2018 5:48 pm
Location: Sevilla

Sun Feb 23, 2020 11:28 pm

Well, it's Monday. :lol:
without window sensor on Gpio9.
with the two lines edited.

Supla_Termostst_oled_H_C_0_96_DOUT_16Mbit.rar
(275.95 KiB) Downloaded 63 times
Supla_Termostst_oled_H_C_1_3_DOUT_16Mbit.rar
(275.9 KiB) Downloaded 58 times
Michal81
Posts: 55
Joined: Sun Feb 02, 2020 9:03 pm

Tue Feb 25, 2020 4:56 pm

Hi.
Thanks for the files.
I tried to play with the code myself yesterday.
Uploading your code from Arduino - the program says: "WARNING: the SuplaDevice library works on avr architecture (/ architectures) and may not be compatible with the current board that works on esp8266 architecture (/ architectures)."
Either there is nothing in the configuration panels, or there is only a part (e.g. without wifi network), or only wifi networks without other settings.
Question: is there a library missing or is it wrong?
Regards.
Attachments
3.jpg
3.jpg (63.28 KiB) Viewed 2927 times
2.jpg
2.jpg (79.42 KiB) Viewed 2927 times
1.jpg
1.jpg (45.84 KiB) Viewed 2927 times
Michal81
Posts: 55
Joined: Sun Feb 02, 2020 9:03 pm

Tue Feb 25, 2020 4:58 pm

Libraries :
Attachments
4.jpg
4.jpg (51.36 KiB) Viewed 2926 times
elmaya
Posts: 911
Joined: Wed Jun 27, 2018 5:48 pm
Location: Sevilla

Tue Feb 25, 2020 5:17 pm

libraries are in the first post.
link
https://en-forum.supla.org/download/file.php?id=7272

The warning is normal.
to come up with Arduino select some size of Flash that has SPIFFS
Michal81
Posts: 55
Joined: Sun Feb 02, 2020 9:03 pm

Tue Feb 25, 2020 5:24 pm

New files BIN. work GREAT
I have libraries from the first post.
I will try to delete and load new libraries again.
Michal81
Posts: 55
Joined: Sun Feb 02, 2020 9:03 pm

Tue Feb 25, 2020 5:43 pm

I changed libraries - it works.
I am full of admiration for the project.
The choice of hot and cooling menus also works great.
Add as much as you can to yesterday's files still adruino files so that you can play with the code yourself and edit.
Michal81
Posts: 55
Joined: Sun Feb 02, 2020 9:03 pm

Thu Feb 27, 2020 8:12 pm

Hello.
Here is the device inserted into the work enclosure.
230V power supply required
In the plans - development of a plate to connect all elements and cut-to-size fittings.

There was a problem - I used such a power supply - 5V, 0.6A.
Connected to the pins: 5V and G on the Wemos board.
After touching the temperature sensor - the ERROR Conimukat appears and the relay switches off. After a while the message disappears, the relay switches on .... in a few seconds again Error ....
When powered by usb - no error occurs.
What could be the reason?
Attachments
zas.jpg
zas.jpg (83.92 KiB) Viewed 2867 times
20200227_203802.jpg
20200227_203802.jpg (2.42 MiB) Viewed 2870 times
jaros12
Posts: 6
Joined: Sat Feb 22, 2020 12:03 pm

Fri Feb 28, 2020 7:32 am

Hi,
@elmaya, my version of Nodemcu doesn't work on Gpio9. I changed to RX and it's OK. Earlier I thought that RX did not work because I waited too short for the sensor to change state. A minor inconvenience - changing the software only with the window open ;)
Michal81
Posts: 55
Joined: Sun Feb 02, 2020 9:03 pm

Sat Feb 29, 2020 3:18 pm

Help.
Elmay, can you tell me the reasons for the Error message when converting the USB power supply to the power supply?
Connected as in the picture:
Attachments
podloczenie zasilacza.jpg
podloczenie zasilacza.jpg (334.29 KiB) Viewed 2783 times
Post Reply

Return to “Ideas and concepts”